• Welcome Guest, The new Modme forums are here! Please visit here for all recommended information.

modric1337

Active member
bigdog those are in harrys pack w one inch punch and staffs. I noticed the wave and zap guns projectiles dont hit panzer soldats, can i change that somehow?
 
bigdog those are in harrys pack w one inch punch and staffs. I noticed the wave and zap guns projectiles dont hit panzer soldats, can i change that somehow?
It’s probably the panzer itself. And either way I highly doubt you would want the wave gun/zap guns to kill him
 

bigdog765

Member
********************************************************************************

UNRECOVERABLE ERROR:

^1SCRIPT ERROR: Preprocessor error, No generated data for 'scripts/zm/_zm_weap_quantum_bomb.gsc'

:112 : (-10) ERROR: Carriage return embedded in string literal







Linker will now terminate.

********************************************************************************

This error pops up regardless if the namestate is changed or not.
still getting this error
 
You can comment all mentions of the qed for this unless you need to have the qed
Now that I think about it, it might be a error in the gsc, there’s a line in the script that should be deleted. Try deleting #using scripts/zm/_zm_weap_quantum_bomb; in _zm_weap_quantum_bomb.gsc
 

Jdcobra

Member
I'm also getting this error when I try to Link

Code:
********************************************************************************
UNRECOVERABLE ERROR:
 ^1SCRIPT ERROR: Preprocessor error, No generated data for 'scripts/zm/_zm_weap_quantum_bomb.gsc'
:111 : (-10) ERROR:  Carriage return embedded in string literal



Linker will now terminate.
********************************************************************************
 

Dedrix

Member
I'm also getting this error when I try to Link

Code:
********************************************************************************
UNRECOVERABLE ERROR:
^1SCRIPT ERROR: Preprocessor error, No generated data for 'scripts/zm/_zm_weap_quantum_bomb.gsc'
:111 : (-10) ERROR:  Carriage return embedded in string literal



Linker will now terminate.
********************************************************************************
Just wondering if you have [LEAKMod] (HarryBo21's perk core) installed in your mod tools?
 

Magicman

Active member
I got everything to link properly.

For people using this, remember when following the instructions to place the #usingscript for the gsc and csc of your map to be placed under #usingscript usermap or else you'll get the same error as I did.

Another problem I had was that my game crashed when throwing the Gerch Device. It would be helpful if I was given the file name for each weapon because when I type in the names from the levelcommon, I can't spawn them in, and are required to be pulled from the box. So any other issues atm are unknown.

I had it all under the #usingscript usermap and I still couldn't get it to work. How exactly did you fix this?
 

Magicman

Active member
Well, it's here. I've decided to release these just due to the fact I'm gonna stop mod tools in a couple of days to pursue career stuff. It's been a long ride and I'm sorry to leave but I have to.

Anyways, this pack includes every wonder weapon from Black Ops 3 Zombies Chronicles, including:
  • Wave Gun / Zap Gun Dual Wield
  • Quantum Entanglement Device
  • 31-79 JGb215
  • Gersh Device
  • Matryoshka Dolls
  • Ray Gun Mark II
  • Sickle
  • Hacker
This pack contains everything that Treyarch did, This wouldn't have been possible without Scobalula, massive thanks to him for the amazing tools.

Download:
GFX Download (Only use if you are missing materials)

Everything is included, but you need to add this to you zm_levelcommon_weapons.csv:

Code:
quantum_bomb,,,2000,quantum,,,,,TRUE,FALSE,FALSE,,,FALSE,FALSE,grenade,,,,
sickle_knife,,,3000,wpck_bowie,,,,,FALSE,FALSE,,,,FALSE,FALSE,special,,,,
nesting_dolls,,,2000,dolls,,,,,TRUE,FALSE,FALSE,,,FALSE,TRUE,grenade,,,,
microwavegundw,microwavegundw_upgraded,,10000,microwavegun,,,,,TRUE,FALSE,TRUE,,,FALSE,FALSE,special,TRUE,TRUE,,
raygun_mark2,raygun_mark2_upgraded,,10000,wpck_ray,,0,,,TRUE,FALSE,TRUE,1,,FALSE,FALSE,special,TRUE,TRUE,,
black_hole_bomb,,,2000,gersh_device,,,,,TRUE,FALSE,FALSE,,,FALSE,FALSE,grenade,,,,
shrink_ray,shrink_ray_upgraded,,10000,shrink_ray,,,,,TRUE,FALSE,TRUE,1,,FALSE,TRUE,special,TRUE,TRUE,,
Credits:
GCPeinhardt: Weapon Ports
Treyarch: Original assets
Scobalula: Cerberus, Greyhound, HydraX, Material Extractor
Wafflez: Sound lines for Mini Zombies

Known Bugs/Issues
You cannot use the Apothican Servant with the Gersh Devices. You have to choose between one or the other.
Wave Gun LUA will look weird, you have to load in the DLC5 lua so it doesn't look weird.
Hacker LUA does not work for some reason.
You may get an error in _zm_weap_quantum_bomb.gsc. This is easily fixed by changing the namespace to zm_weap_quantum_bomb (This has now been fixed)

NOTE: YOU MUST USE THE USERMAP ZOMBIES SPAWNER! DO NOT USE FACTORY SPAWNER!!!

If you want to use custom zombies, look in the wpn_t7_zmb_hd_microwavegun_zombie_models.gdt and wpn_t7_zmb_hd_shrinkray_fun_size.gdt and copy what I did to get the models. You will have to create materials that have _bloat on the end so the zombies can expand. I would then duplicate this and change the model scale so I could make the baby zombies. The function to adding custom models for the baby zombies is in the instructions.

Update v1.2
  • Added GFX download for people who are missing materials

Update v1.1
  • Fixed Quantum Bomb script
  • Added sound templates for those who don't have it

I followed the directions and everytime I start the game, my player can't move and when I try to jump, it crashes the game. Did you ever have this error?
 
I have had no problems installing this myself. My other friends have had no problems either. You do not need L3AKMOD to use this, as all of the LUA is loaded already and there is no compiled (gscc, cscc) code.
 

Magicman

Active member
I have had no problems installing this myself. My other friends have had no problems either. You do not need L3AKMOD to use this, as all of the LUA is loaded already and there is no compiled (gscc, cscc) code.
I do have L3AKMOD if I uninstall it, should the weapons work?

I have also discovered that I can unfreeze my player by shooting
 
Last edited:
Top