• Welcome Guest, The new Modme forums are here! Please visit here for all recommended information.

Elemental Bows

Spiki

Undead member
Thread By: mathfag
Elemental Bows
<hr><hr>
Pack contains:
Wrath of the Ancients
Storm bow
Wolf bow
Magma bow
Void bow

Dragon
Bow quest

as seen on my map "Chernobyl"
<hr>Credits:
Models/Maya work: Artleck
Everything else: SomeDudesFatMom a.k.a. Mathfag a.k.a. Spiki
Beta testing:
-Phane
-TrueGamerCalls
<hr>
Discalimers:

  • The dragon and Bow quest script were added as a bonus so no support is given for them on this thread although prefabs, instructions and instructions to remove them are included in the pack. If you don't do radiant work, nothing will happen. Bottom line: don't ask about them on this thread.


<hr>





<hr>Download:

Koan ruined the joke.
Download

<hr>V1 (10.4.18): Release
V1.0.1 (11.4.18): Removed the LUA from .csc, added animtree, commented the #using dragon script so it's off by default. Added dragon assets.
V1.1 (3.5.18): Added sound files, fixed instructions

FAQ:
Q: Sounds aren't working.
A: If the launcher isn't giving you any direct message, go to BO3/usermaps/mapname/zone/snd and delete all the sound folders, then keep relinking until all the .sabl and .sabs files regenerate.

Q: I don't have chernobyl
A: Search for it in the workshop...

Known issues:
//
 

ModmeBot

Modme hero
Reply By: Abnormal202
Can't to wait to paint some sick flames on these bows.

Maybe I'll even attach a spoiler
 

ModmeBot

Modme hero
Reply By: TCM
mathfag
Elemental Bows Pack contains: Wrath of the Ancients Storm bow Wolf bow Magma bow Void bow Dragon Bow quest as seen on my map "Chernobyl" Credits: Models/Maya work: ArtleckEverything else: SomeDudesFatMom a.k.a. MathfagBeta testing:phane-TrueGamerCalls Discalimers: Since it would make the filesize too big, I have not included the voxs for the bow/dragon. You can aquire these sounds from Der Eisendrache of my map. They are not needed for the bows to function. They just make them cooler. The dragon and Bow quest script were added as a bonus so no support is given for them on this thread although prefabs, instructions and instructions to remove them are included in the pack. If you don't do radiant work, nothing will happen. Bottom line: don't ask about them on this thread. Download: [Spoilers] Show / Hide You can use these on the condition that you don't chop-top the bow like one of those beaners, don't paint any idiotic flames on it like some white trash hillbilly, and don't put a big, gay spoiler on the rear end like you see on all the other zipperheads' bows. It just looks like hell. If you can refrain from doing any of that... it's yours." Forgot the prefabs: Known bugs: -//
What is the link to your map as well as how would we go about ripping what is needed?
 

ModmeBot

Modme hero
Reply By: TCM
mathfag
Elemental Bows Pack contains: Wrath of the Ancients Storm bow Wolf bow Magma bow Void bow Dragon Bow quest as seen on my map "Chernobyl" Credits: Models/Maya work: ArtleckEverything else: SomeDudesFatMom a.k.a. MathfagBeta testing:phane-TrueGamerCalls Discalimers: Since it would make the filesize too big, I have not included the voxs for the bow/dragon. You can aquire these sounds from Der Eisendrache of my map. They are not needed for the bows to function. They just make them cooler. The dragon and Bow quest script were added as a bonus so no support is given for them on this thread although prefabs, instructions and instructions to remove them are included in the pack. If you don't do radiant work, nothing will happen. Bottom line: don't ask about them on this thread. Download: [Spoilers] Show / Hide You can use these on the condition that you don't chop-top the bow like one of those beaners, don't paint any idiotic flames on it like some white trash hillbilly, and don't put a big, gay spoiler on the rear end like you see on all the other zipperheads' bows. It just looks like hell. If you can refrain from doing any of that... it's yours." Forgot the prefabs: Known bugs: -//
Seems as though adding this and setting it up exactly as you said broke the compilation process.

For one error is

PHP:
[L3akMod (D3V)] Error: Could not find ui/uieditor/menus/hud/t7hud_zm_custom.lua
 

ModmeBot

Modme hero
Reply By: TCM
D-2-K
have u even installed lua
But as you can see thats not even the error, its trying to find a file. Also in the installation guild you put this

PHP:
mapname.gsc/.csc:
#using scripts\zm\_zm_weap_elemental_bow;

When you have the files in the directory of

PHP:
scripts\zm\bow\_zm_weap_elemental_bow;
 

ModmeBot

Modme hero
Reply By: TCM


I found where that was being called commented it out to see and it looks as if he didn't include a whole folder of stuff from

PHP:
 ui/uieditor/widgets/
 

ModmeBot

Modme hero
Reply By: D-2-K
TCM
D-2-K have u even installed lua But as you can see thats not even the error, its trying to find a file. Also in the installation guild you put this mapname.gsc/.csc: #using scripts\zm\_zm_weap_elemental_bow; When you have the files in the directory of scripts\zm\bow\_zm_weap_elemental_bow;

Check the file location for that as it should be t7hud_zm_custom.luac not .lua so it would most likely be that something in the bow scripts is looking for the older version of harrys file which was originaly a .lua but has been changed so if you're using harry's latest files yours should be t7hud_zm_custom.luac and somethings looking for the older version named t7hud_zm_custom.lua
 

ModmeBot

Modme hero
Reply By: TCM
D-2-K
TCM D-2-K have u even installed lua But as you can see thats not even the error, its trying to find a file. Also in the installation guild you put this mapname.gsc/.csc: #using scripts\zm\_zm_weap_elemental_bow; When you have the files in the directory of scripts\zm\bow\_zm_weap_elemental_bow; Check the file location for that as it should be t7hud_zm_custom.luac not .lua so it would most likely be that something in the bow scripts is looking for the older version of harrys file which was originaly a .lua but has been changed so if you're using harry's latest files yours should be t7hud_zm_custom.luac and somethings looking for the older version named t7hud_zm_custom.lua
Look at what I said above it seems as though some files with release where left out, and I use the modified DLL for harry's stuff, He doesn't actually use that file for any of his things. Its something missing with the release.

Yeah then when starting if I comment those lines out it gives error linking mapname, It breaks the map completely.
 

ModmeBot

Modme hero
Reply By: D-2-K
TCM
D-2-K TCM D-2-K have u even installed lua But as you can see thats not even the error, its trying to find a file. Also in the installation guild you put this mapname.gsc/.csc: #using scripts\zm\_zm_weap_elemental_bow; When you have the files in the directory of scripts\zm\bow\_zm_weap_elemental_bow; Check the file location for that as it should be t7hud_zm_custom.luac not .lua so it would most likely be that something in the bow scripts is looking for the older version of harrys file which was originaly a .lua but has been changed so if you're using harry's latest files yours should be t7hud_zm_custom.luac and somethings looking for the older version named t7hud_zm_custom.lua Look at what I said above it seems as though some files with release where left out, and I use the modified DLL for harry's stuff, He doesn't actually use that file for any of his things. Its something missing with the release. Yeah then when starting if I comment those lines out it gives error linking mapname, It breaks the map completely.
the file is not in widgets

its here F:\SteamLibrary\steamapps\common\Call of Duty Black Ops III\share\raw\ui\uieditor\menus\hud yours should be called t7hud_zm_custom.luac and its looking for


PHP:
ui/uieditor/menus/hud/t7hud_zm_custom.lua
 

ModmeBot

Modme hero
Reply By: TCM
D-2-K
TCM D-2-K TCM D-2-K have u even installed lua But as you can see thats not even the error, its trying to find a file. Also in the installation guild you put this mapname.gsc/.csc: #using scripts\zm\_zm_weap_elemental_bow; When you have the files in the directory of scripts\zm\bow\_zm_weap_elemental_bow; Check the file location for that as it should be t7hud_zm_custom.luac not .lua so it would most likely be that something in the bow scripts is looking for the older version of harrys file which was originaly a .lua but has been changed so if you're using harry's latest files yours should be t7hud_zm_custom.luac and somethings looking for the older version named t7hud_zm_custom.lua Look at what I said above it seems as though some files with release where left out, and I use the modified DLL for harry's stuff, He doesn't actually use that file for any of his things. Its something missing with the release. Yeah then when starting if I comment those lines out it gives error linking mapname, It breaks the map completely. the file is not in widgets its here F:\SteamLibrary\steamapps\common\Call of Duty Black Ops III\share\raw\ui\uieditor\menus\hud yours should be called t7hud_zm_custom.luac and its looking for ui/uieditor/menus/hud/t7hud_zm_custom.lua
Yes I understand that but he also references more files which are not there as well such as these

PHP:
rawfile,ui/uieditor/widgets/zminventory/BowStormWidget.lua
rawfile,ui/uieditor/widgets/zminventory/BowWolfWidget.lua
rawfile,ui/uieditor/widgets/zminventory/BowMagmaWidget.lua
rawfile,ui/uieditor/widgets/zminventory/BowVoidWidget.lua
 

ModmeBot

Modme hero
Reply By: D-2-K
TCM
D-2-K TCM D-2-K TCM D-2-K have u even installed lua But as you can see thats not even the error, its trying to find a file. Also in the installation guild you put this mapname.gsc/.csc: #using scripts\zm\_zm_weap_elemental_bow; When you have the files in the directory of scripts\zm\bow\_zm_weap_elemental_bow; Check the file location for that as it should be t7hud_zm_custom.luac not .lua so it would most likely be that something in the bow scripts is looking for the older version of harrys file which was originaly a .lua but has been changed so if you're using harry's latest files yours should be t7hud_zm_custom.luac and somethings looking for the older version named t7hud_zm_custom.lua Look at what I said above it seems as though some files with release where left out, and I use the modified DLL for harry's stuff, He doesn't actually use that file for any of his things. Its something missing with the release. Yeah then when starting if I comment those lines out it gives error linking mapname, It breaks the map completely. the file is not in widgets its here F:\SteamLibrary\steamapps\common\Call of Duty Black Ops III\share\raw\ui\uieditor\menus\hud yours should be called t7hud_zm_custom.luac and its looking for ui/uieditor/menus/hud/t7hud_zm_custom.lua Yes I understand that but he also references more files which are not there as well such as these rawfile,ui/uieditor/widgets/zminventory/BowStormWidget.lua rawfile,ui/uieditor/widgets/zminventory/BowWolfWidget.lua rawfile,ui/uieditor/widgets/zminventory/BowMagmaWidget.lua rawfile,ui/uieditor/widgets/zminventory/BowVoidWidget.lua
well those are on him if there missing im just pointing out your original error that somethings looking for the older version of harry's file that is no longer a lua its now luac



Edit: and you are correct i dont see any ui folder in the download had to check ;)
 

ModmeBot

Modme hero
Reply By: TCM
D-2-K
TCM D-2-K TCM D-2-K TCM D-2-K have u even installed lua But as you can see thats not even the error, its trying to find a file. Also in the installation guild you put this mapname.gsc/.csc: #using scripts\zm\_zm_weap_elemental_bow; When you have the files in the directory of scripts\zm\bow\_zm_weap_elemental_bow; Check the file location for that as it should be t7hud_zm_custom.luac not .lua so it would most likely be that something in the bow scripts is looking for the older version of harrys file which was originaly a .lua but has been changed so if you're using harry's latest files yours should be t7hud_zm_custom.luac and somethings looking for the older version named t7hud_zm_custom.lua Look at what I said above it seems as though some files with release where left out, and I use the modified DLL for harry's stuff, He doesn't actually use that file for any of his things. Its something missing with the release. Yeah then when starting if I comment those lines out it gives error linking mapname, It breaks the map completely. the file is not in widgets its here F:\SteamLibrary\steamapps\common\Call of Duty Black Ops III\share\raw\ui\uieditor\menus\hud yours should be called t7hud_zm_custom.luac and its looking for ui/uieditor/menus/hud/t7hud_zm_custom.lua Yes I understand that but he also references more files which are not there as well such as these rawfile,ui/uieditor/widgets/zminventory/BowStormWidget.lua rawfile,ui/uieditor/widgets/zminventory/BowWolfWidget.lua rawfile,ui/uieditor/widgets/zminventory/BowMagmaWidget.lua rawfile,ui/uieditor/widgets/zminventory/BowVoidWidget.lua well those are on him if there missing im just pointing out your original error that somethings looking for the older version of harry's file that is no longer a lua its now luac

Yes I found what was looking for it, It was his script as well looking for it its right above the ones I just posted.
 

ModmeBot

Modme hero
Reply By: TCM
D-2-K
change it to luac instead of lua let me know what happens
That is what I am saying, The addon breaks everything in the map because its looking for multiple LUA files he added so as soon as I change it sure it gets past that point, But then it just says missing the next lua file that was not included.
 

ModmeBot

Modme hero
Reply By: D-2-K
TCM
D-2-K change it to luac instead of lua let me know what happens That is what I am saying, The addon breaks everything in the map because its looking for multiple LUA files he added so as soon as I change it sure it gets past that point, But then it just says missing the next lua file that was not included.
sound my friend good to know he'll need to add the other files and update the script or add a disclaimer to change that 1 line
thanks for the feedback though
 

ModmeBot

Modme hero
Reply By: Harry Bo21
its only trying to include the lua files he missed in your zone

the fact they are missing wont break anything, because nothing is actually trying to "use" them



the missing lua of mine - which indeed should be .luac not .lua - "will" be breaking shit however, coz the games actually trying to "use" it
 

ModmeBot

Modme hero
Reply By: TCM
Harry Bo21
its only trying to include the lua files he missed in your zone the fact they are missing wont break anything, because nothing is actually trying to "use" them the missing lua of mine - which indeed should be .luac not .lua - "will" be breaking shit however, coz the games actually trying to "use" it

Yeah at this point just waiting for him to get back on and see what is going on.
 
Top