• Welcome Guest, The new Modme forums are here! Please visit here for all recommended information.

Released PHD Flopper Perk v1.0

Hi everyone! Today I am releasing my PHD Flopper perk. Included is everything you need to have PHD in your map

Credits

GCPeinhardt - Remade perk model and textures, scripting
HarryBO21 - Helped with scripting, perk fx
Erthrock - Shader
MotoLegacy - Shader
Scobalula - Greyhound, HydraX
DTZxPorter - LUA help
Treyarch - Original assets and scripts

FX

Model

Download:
 
Last edited:

Mindmirror

New member
There are at least four mistakes i can report so far:
1. The image name in the zone is wrong. It does not match with the ones in APE. It has to be: image,specialty_divetonuke_zombies Also this image is missing at all.
2. In line 168 of _zm_perk_phd_flopper.gsc there is a ")" missing at the end of "self visionset_mgr::activate("visionset", PHD_FLOPPER_VISION, self);"
3. There is no PhD flopper vending prefab.
4. These FX are missing:

^1ERROR: Material gfx_flamethrower_smoke was not found in gdtDB

material:ei/gfx_flamethrower_smoke
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def3':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def6':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def3':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def6':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
 
There are at least four mistakes i can report so far:
1. The image name in the zone is wrong. It does not match with the ones in APE. It has to be: image,specialty_divetonuke_zombies Also this image is missing at all.
2. In line 168 of _zm_perk_phd_flopper.gsc there is a ")" missing at the end of "self visionset_mgr::activate("visionset", PHD_FLOPPER_VISION, self);"
3. There is no PhD flopper vending prefab.
4. These FX are missing:

^1ERROR: Material gfx_flamethrower_smoke was not found in gdtDB

material:ei/gfx_flamethrower_smoke
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def3':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def6':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def3':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def6':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
Ahh, thanks for bringing this stuff up. I’ll fix this up then.
 
There are at least four mistakes i can report so far:
1. The image name in the zone is wrong. It does not match with the ones in APE. It has to be: image,specialty_divetonuke_zombies Also this image is missing at all.
2. In line 168 of _zm_perk_phd_flopper.gsc there is a ")" missing at the end of "self visionset_mgr::activate("visionset", PHD_FLOPPER_VISION, self);"
3. There is no PhD flopper vending prefab.
4. These FX are missing:

^1ERROR: Material gfx_flamethrower_smoke was not found in gdtDB

material:ei/gfx_flamethrower_smoke
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def3':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def6':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def3':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
^3effect 'explosions/fx_zmb_phdflopper_exp' segment 'wraith_looping_def6':
material ei/gfx_flamethrower_smoke has an invalid atlas, 0 x 0
fx:explosions/fx_zmb_phdflopper_exp
updated now
 

Khramos

Well-known member
Hi everyone! Today I am releasing my PHD Flopper perk. Included is everything you need to have PHD in your map

Credits

GCPeinhardt - Remade perk model and textures, scripting
HarryBO21 - Helped with scripting, perk fx
Erthrock - Shader
MotoLegacy - Shader
Scobalula - Greyhound, HydraX
DTZxPorter - LUA help
Treyarch - Original assets and scripts

FX

Model

Download:
Someone please make a mod adding this and the old weapons to the ZC maps.
 

Drae77

New member
Code:
^1ERROR: Material gfx_flamethrower_fire_add was not found in gdtDB

  material:ei/gfx_flamethrower_fire_add
    fx:explosions/fx_zmb_phdflopper_exp
      csv:zone_source/zm_espada.zone

^3techsetdef 'effect_lit_blend#da7372ff' doesn't support material type '' (0)

  material:gfx_crater_dirt
    fx:explosions/fx_zmb_phdflopper_exp
      csv:zone_source/zm_espada.zone
^1effect_simple.hlsl#99525c21: Shader preprocessor error:
D:\Steam\steamapps\common\Call of Duty Black Ops III\bin\<memory>(29,10-29): error X1507: failed to open source file: 'effect_simple.hlsl'

  DRAW_METHOD:ship
    techset:effect_lit_blend#da7372ff
      material:gfx_crater_dirt
        fx:explosions/fx_zmb_phdflopper_exp
          csv:zone_source/zm_espada.zone
^1effect_simple.hlsl#99525c21: Shader preprocessor error:
D:\Steam\steamapps\common\Call of Duty Black Ops III\bin\<memory>(29,10-29): error X1507: failed to open source file: 'effect_simple.hlsl'

  DRAW_METHOD:ship
    techset:effect_lit_blend#da7372ff
      material:gfx_crater_dirt
        fx:explosions/fx_zmb_phdflopper_exp
          csv:zone_source/zm_espada.zone
^1effect_simple.hlsl#8f9d82e2: Shader preprocessor error:
D:\Steam\steamapps\common\Call of Duty Black Ops III\bin\<memory>(29,10-29): error X1507: failed to open source file: 'effect_simple.hlsl'
How can i resolve this ? im having troubles on installing it. Hope u can help me bro thanks in advance .

p.d: sorry for my bad english :D
 
Top