Modme Forums

Zombie Pathing/Navigation Issue. Won’t Even Move.

Game Modding | Call of Duty: Black Ops 3 | General Discussion


I'm pretty desperate for some help!

Short story: My map's zombies either don't move, get stuck, or follow me until suddenly deciding to turn and run into a wall instead.

Long story:
I'm sorry for the lengthy description - I'm just trying to be as detailed as possible since I can't find anything recent or relevant to my specific problem on the internet anywhere.
Below is a video showing these pathing/navigation issues that includes some still frames of what those areas look like in radiant with the zone volumes and door triggers.

There are three clips in this video of different times I tested the map, each with a separate (but likely related) problem.
The first shows zombies that properly broke their barriers and began to follow me, however, when I went around to the other side of the wall (all within the same zone, the start zone), they tried to walk directly to me and were indefinitely stuck trying to go through the wall.
The second and third clips show zombies spawning from riser locations and then going idle until I got extremely close to them. After becoming aggro, if I back away far enough they go idle again.
Interestingly, in the third clip, the zombies that spawned in the courtyard (in the adjacent zone) seemed to not be able to see me past the zone barrier.
When I went back into that zone, they followed me. When I left, they randomly went towards the fence post and forgot about me.
In the first clip, though, a zombie spawned in that barrier while I was watching the other ones try to get me through the wall, and he was able to see me and chase me through that zone barrier.
It all seems very inconsistent but I reckon there is one main issue that is causing all of this of which I'm unaware.

Some things I've tried/have implemented already
- All the riser spawn scripts have KVPs of script_string, find_flesh (highlighted because this is everyone's first proposed solution).
- I've added monster and default clips to the walls (even though they are brushes) to see if they'd go around them. They still don't.
- I added a nav volume to encompass all the zones. It didn't seem to make a difference, but honestly I'm not really sure how those work.
- I tried opening the Navigation Mesh tool and pressed 'generate.' I have no idea if it did anything, because nothing was visibly different.
In game, I entered dev mode and tried the 'ai_showNavMesh 1' thing, but I couldn't see anything. I can't tell if I'm doing that wrong or if there literally is no nav mesh on my map.

If anyone has any helpful insight, I would be eternally grateful. Thank you! :)

Click here for video


Did you put a slash in front of the console command, like

/ai_shownavmesh 1
? The commands don't work unless you do that for whatever reason.


Did you put a slash in front of the console command, like
/ai_shownavmesh 1
? The commands don't work unless you do that for whatever reason.

Unfortunately yes, and I actually just tried it again. For a while I saw nothing, then I saw some lines running diagonally across my map but nothing else as I ran around to all the locations. I also began seeing through several of my solid textured walls, sometimes flickering between opaque and transparent. Starting to think it might not be a relatively simple solution and my map is seriously bugged out somehow. Thanks for your help and let me know if you think of anything else!